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Rigging in DS4 Pro
PREPERATION 
 
Generally, you'll want to start with an object consisting mostly of quads (polygons), with minimal tris (3 sided faces) and 
no ngons (5+ sided faces). If your object is triangulated, it shouldn't interfere with rigging, but quads are preferred, as they 
are easier to group and uv unwrap among other things. 
 
It is useful to work with your preview mode set to "Wire Shaded."  
 
Load in your object, making sure it is the proper scale for your uses. Load up another figure for size reference if necessary. 
 
Before you start rigging your model, think of the way the actual skeleton of the real animal you are making, or that of a 
similar animal, is laid out. 
 
For my model, there should be a skull, several thoracic (neck) vertebrae, ribcage, hip, tail, right and left thighs, legs, feet, 
and toes. (Fig. 1) 
 

 
 

Now, we want to visualize which vertices should be affected by those bones. 
 
STEP 1: GROUPING 
 
With your object selected in your scene, activate the polygroup editor, by clicking the icon from your Viewport Tools (Fig. 
2b), or striking Alt+Shift+G on the keyboard. 
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Right click, and select Polygon Selection>Mode>Lasso Selection (Fig. 3). This will allow you to select groups of polys 
easily with your mouse. It selects all polys in the lasso area, even the ones you can't see. So, when you make a selection 
with the lasso mode, you will want to check to make sure you haven't selected any polys you don't want. We will use 
other selection modes later. 
 

 
 

I will now select the polys of the head. (Fig. 4) 
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In the Tool Settings Pane, right-click on "Face Groups." (Fig. 5) 
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I will name the new group "head." 
 
Right-click on the "head" group, and select "Assign Selected Faces to Group." (Fig. 6) 
 

 
 

Now, I will do the same for 5 "neck" groups and a "chest" group: chest, neck1, neck2, neck3, neck4, and neck5. (Fig. 7) 
You will notice, that as you add polys to new groups, the vertex count of the default group grows smaller. This is because 
a poly can only belong to one face group at a time. So, as a selected poly is added to a new group, it is removed from any 
group it belonged to before. 
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Next, I will do the tail, because the boundaries of the hip will be based on it, as well as the thigh groups. For this group, I 
will select the two polys on the end of the tail. I will now grow selection by striking Ctrl++. (Fig. 8 & 8b) This allows me 
to easily select as much of the area as I want in a symmetrical way without including the overlapping wingfeathers. I create 
a new group named "tail," and assign these polys to it. 
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After the tail, I select the tips of the toes. (Fig. 9) I will name this group "rtoes1" (For this particular purpose, I want 
to minimize the number of bones in the armature, so I am rigging all of the toes as one, but you could group/rig 
them individually if you want to). By default, when you begin to select polygons, it will treat this as a new selection, 
and deselect any previously selected polygons. To add polygons to an existing selection, hold the Ctrl key while selecting 
the new polygons. 
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With rtoes1 assigned, I grow the selection out a couple of times until it reaches halfway up the next toe joint. You will 
notice that four polygons on the middle toe are not selected (Fig. 10), though they should be. Ctrl+Left Click will add 
those polygons to the selection (Fig. 10b).  
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Since I don't want to remove the selected polys from the rtoes1 group, I need to deselect them. To remove those polys from 
the selection, find the group in the Tool Settings pane, and click the small "-" between the "+" and "eye" buttons. (Fig. 11) 
I will now assign this selection to a group named "rtoes2." 
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I grow the selection again. You will notice that growing the selection expands it in all directions. The selection now 
includes unassigned polys as well as polys from "rtoes2" and "rtoes1." I remove "rtoes2" and "rtoes1" from the selection 
as outlined above, and assign the new selection to a group named "rtoes3." 
 
I use the same technique for an "rfoot" group, and an "rleg" group. 
 
Now, for the thigh. On my duck model, the wing is incorporated into the model. The movement of the thigh does not affect 
the wing as much as the movement of the hip, so I don't want to include that part of the model in my group, since I will 
be basing the vertex weighting on these groups. So, I grow the "rleg" group once, and refine the selection by Ctrl+left 
Clicking the polys I think the thigh bone should affect most. 
 
Now that I have the right leg grouped, I need to group the left leg. Currently, there is no way to mirror the 
grouping automatically, so you will have to try to eyeball it. Try to keep your groups as symmetrical as possible. Obviously, 
it is much easier to do with a lowerpoly model. An easy way to check for symmetrical groups, is to cross-reference 
their polycounts. (Fig. 12, both rtoes1 and ltoes1 have 91 polys) 
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For the last group, the hip, I have made a wide selection with the lasso polygroup selection mode, and removed all of 
the groups that shadred polys with the selection, so that none of them would be affected. (Fig. 13 shows the final selection 
for the hip group). 
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Once your last group is assigned, your default group should show a count of "0." If there are still unassigned polys, click on 
the default group. The polys still belonging to it will be highlighted in red. 
 
The grouping step is now complete. Now, export your grouped model as a wavefront object. The best settings for export 
is usually the DAZ Studio preset, for a project like this. Be sure that "Write Groups" is checked, with "Use Existing 
Groups" chosen in the individual settings. When reimporting, be sure to use the same settings you used to export it. 
 

file:///C|/Users/Sparky/Documents/Tutorial%20Files/DAZ%204/Mine/DS4ProRigging/DS4ProRiggingTutorial.html (13 of 28) [3/24/2012 5:00:32 PM]



file:///C|/Users/Sparky/Documents/Tutorial%20Files/DAZ%204/Mine/DS4ProRigging/DS4ProRiggingTutorial.html

 
 

Delete your model from the scene. 
 
STEP 2: RIGGING 
 
Open the Figure Setup panel. Under the "Geomestries List," right-click and choose "Add Geometry." (Fig. 15) Browse to 
the file you previously exported. Expand it to see all the groups in your model. Your Figure Setup panel should now look 
like Fig. 16. 
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Drag your geometry onto the Geometry reference in the window titled "Relationships." Your Figure Setup Panel should 
now look like Fig. 17.  
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Now, you will need to setup your figure's hierarchy. The root of most Poser/DS figures is the hip. It is useful to stick to 
this convention, so, the hierarchy of my Duck should be as follows: 
 
hip 

tail 
chest 

neck5 
neck4 

neck3 
neck2 

neck1 
head 

rthigh 
rleg 

rfoot 
rtoes3 

rtoes2 
rtoes1 

lthigh 
lleg 

lfoot 
ltoes3 

ltoes2 
ltoes1 

 
 
To make one bone a child of another, drag it onto its parent. 
 
After sorting the hierarchy, my Figure Setup Panel begins to look like Fig. 18. 
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Choose your rotation order, if you know what you're about. If you aren't sure, then we can edit that later, and more visually, 
in the viewport with the joint editor. 
 
For now, just click "Create." What I get looks like what you see in Fig. 19. 
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The Joints now need adjustment. Activate the Joint Editor Tool by clicking on the bone and pencil icon (Fig. 20) in 
the Viewport Tools or striking Alt+Shift+J on the keyboard. 
 

 
 

With the Joint Editor Tool active, right-click on your figure, and choose Align>Align All Bones (Fig. 21). That will realign 
all the bones in your armature to their endpoints. Some joints still need work, however. Move the center and endpoints of 
your bones using the green (center) and red (end) handles to postition. 
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If your figure has symmetrical appendages, such as my Duck's legs, you can mirror your adjustments to the armature.  
 
To mirror only that part of the armature (and prevent any unwanted changes to other joints) select the parent of the 
appendage. In this case, it is "rthigh." Right-click and select Edit>Mirror Joints (Fig. 22). 
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In the dialog that pops up, choose "Selected Recursive" under "Node," "Selected to Opposite" under "Direction," and "X" 
under "Axis." 
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That should take care of the legs.  
 
However, I would like to center the neck bones a little more, but I don't want to have to move each one individually, given 
that they are so nicely aligned now. To move them all, I will turn on "Propagate Translations" (Right Click 
Edit>Propagate Translations, Fig. 24) 
 

 
 

This will cause all children of any bone we move from the centerpoint to follow that translation. Here (Fig. 25), I have 
adjusted the position of neck 5 with Propagate Translations on, and neck4, neck3, neck2, neck1, and head followed 
that adjustment. 
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This armature looks like it will serve well enough for the next step. To finalize, Right-Click, choose 
Memorize>Memorize Figure Rigging (Fig. 26). Be sure you don't skip this step, or your figure's armature will revert to 
its original state. 
 

 
 

STEP 3: WEIGHTING 
 
Activate the Weight Map Brush by clicking the brush and barbells icon (Fig. 27) in the Viewport Tools, or by striking Alt
+Shift+W on the keyboard. 
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When you Right-Click with the Weight Map Brush active, you will notice that the menu includes some polygroup 
commands in addition to the new weight mapping commands. These will come in very handy. 
 
To start, have the Tool Settings and Scene Panels where you can see them both (I have mine docked on the left and 
right respectively). 
 
Select the root bone of your figure in the Scene Panel, in my case, it is "hip." 
 
You will notice in the Tool Settings Panel that three weights are displayed, X, Y, and Z. Select the X rotation map. Your 
figure should be displayed in red. (Fig. 28) 
 

 
 

Red represents 100% influence. The Figure Setup process automatically assigns full influence to the root of your figure. If 
you click on any other bones, you will notice that they are represented by all blue, and, if you rotate the bone, nothing 
happens. This is what we will need to work on. 
 
So, in the Scene Panel, select the next bone in your hierarchy, in my case, "tail." In the Tool Settings Panel, select the 
X Rotation map. Right-Click in the viewport, and choose Polygon Selection>Select>Face Groups>tail. (Fig. 29) That 
will select the polygons of the tail face group.  
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To weight the selected polygons to the selected bone, Right-Click, and choose "Fill Selected Faces." (Fig. 30) That turns 
my tail red, and if I rotate the tail bone on the X-axis, that geometry is deformed by the bone now.  
 

file:///C|/Users/Sparky/Documents/Tutorial%20Files/DAZ%204/Mine/DS4ProRigging/DS4ProRiggingTutorial.html (24 of 28) [3/24/2012 5:00:32 PM]



file:///C|/Users/Sparky/Documents/Tutorial%20Files/DAZ%204/Mine/DS4ProRigging/DS4ProRiggingTutorial.html

 
 

However, it looks very abrupt and hard-edged. To fix that, I will grow the poly selection (Ctrl++) and Right-Click, 
choose "Smooth Selected Faces." In the dialog that pops up, I used a Smooth Factor of about 9, and 51 Iterations. (I forgot 
to take screenshots of this part, but it shouldn't be difficult to understand without them.) 
 
Now my tail bends smoothly. (Fig. 31) 
 

file:///C|/Users/Sparky/Documents/Tutorial%20Files/DAZ%204/Mine/DS4ProRigging/DS4ProRiggingTutorial.html (25 of 28) [3/24/2012 5:00:32 PM]



file:///C|/Users/Sparky/Documents/Tutorial%20Files/DAZ%204/Mine/DS4ProRigging/DS4ProRiggingTutorial.html

 
 

In the Tool Settings Panel, Right-Click on the X Rotation map and choose "Copy Selected." (Fig. 32) Now, Right-Click on 
the Y Rotation map and choose "Paste Selected." Do the same for the Z Rotation map. That will make sure you have 
weights for all axes, as well as preserving a sort of "backup" of the weights for this bone should you accidentally damage 
them later. You can tweak the maps for each axis later, for now, just concentrate on the X-axis. 
 

 
 

Right-Click and choose Polygon Selection>Clear Selection to remove the tail polygons from the selection. It is very 
important to remember to clear your polygon selection before moving on to the next bone, or you may damage previous 
weight maps by filling a new map with polys affected by another. 
 
Do as I have done for the tail bone for each of your figure's bones. Select the face group, fill 100%, Grow Poly 
Selection, Smooth, Copy X Rotation map to Y and Z. 
 
Once that is done, your figure should show deformations when you rotate the bones in your armature. But you will no 
doubt want to do some extra tweaking to your weights. Use the Smooth mode of the Weight Map Brush to make 
fine adjustments. 
 
Once you have your figure moving with your armature to your satisfaction, it is time to save your work (if not before ;-)). Go 
to File>Save As>DSF Figure or Prop File... (Fig. 33). Fill in the dialog that pops up, mine looked like Fig. 33b. 
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